Blender для начинающих/Меню

Материал из Викиучебника — открытых книг для открытого мира
Перейти к навигации Перейти к поиску
Blender2017.png



OpenHK2.jpg - перейти к комбинациям клавиш.
Level2.jpg - перейти к первому необязательному для изучения разделу.
NextChapter.jpg - переход к следующей по курсу главе (порядок глав не совпадает с порядком глав по содержанию).

CTRL+ALT+U

CTRL+U

SHIFT+S

CTRL+Q

A

R

G

S

SHIFT+D

ALT+D

CTRL+NUMPAD+

CTRL+NUMPAD-

SHIFT+L

SHIFT+G

ALT+M

F

CTRL+ALT+SHIFT+C

SHIFT+S

D

T

I

Shift+B

B

C

Одни из главных классов Python: bpy.ops | bpy.data | bpy.types.ID

Рендеринг Рендер-ферма
Отсечение Шейдер
Трассировка лучей Сжатие текстур

Расположение элементов интерфейса


Ссылки на материалы
Возможно, Вас заинтересует следующее:
О Blender 2.76 FInfo.jpg Скачать Blender 2.76 FDownload.jpg

3D View[править]

Меню View[править]

BlenderMenu1.jpg

  1. Команда «Toggle Maximize Area» увеличит до максимальных размеров то окно, в котором Вы последний раз работали.
  2. «Toggle Quard View» - разделит область 3D вида на 4 - вид спереди, справа, сверху и вид с перспективой.
  3. «View All» - покажет все видимые объекты на сцене.
  4. «View Selected» - приблизится к всем выделенным объектам.
  5. Команда «View Global/Local» позволяет скрывать все остальные объекты, кроме выделенных, или отображать все объекты на сцене. Когда все объекты снова отобразятся на сцене, могут быть не видны объекты, которые были спрятаны с помощью H, до применения этой команды.
  6. «Show Layers» - данная опция включит отображения всех объектов со всех слоев.
  7. Используя «Render Border», можно выбрать лишь часть 3D вида, которая будет визуализироваться в режиме «Rendered». Рамка устанавливается также, как и при работе с выделением прямоугольником (B).
  8. «Zoom Border» - приблизиться к тем объектам, которые попадут в прямоугольное выделение.
  9. Также можно установить вид проекции или вид из камеры, используя такие пункты меню:
    1. «Left» - вид слева
    2. «Right» - вид справа
    3. «Back» - вид сзади
    4. «Left» - вид слева
    5. «Front» - вид спереди
    6. «Bottom» - вид снизу
    7. «Top» - вид сверху
    8. «Camera» - вид из активной (камеры, в которую пользователь попадает, нажимая на 0 (NumPad))
  10. Можно включить или выключить отображение панели инструментов, нажав на «Tool Shelf».
  11. Также есть возможность скрыть или показать панель свойств объекта.

Меню Select[править]

BlenderMenu2.jpg

  1. С помощью команды «Select Pattern» можно выделить по шаблону объекты. Введите некоторый шаблон, и выделятся объекты, имена которых удовлетворяют данному шаблону.
    1. Маски (шаблоны составляются по правилам):
      1. * - любое количество произвольных символов
      2.  ? - один произвольный символ
      3. Пример маски, под которую попадут объекты с именами «ObjAMy», «ObjTreeMy»: «Obj*My».
  2. «Select Camera» - будет выделена активная камера. Все выделенные до этого объекты станут не выделенными.
  3. Используя функцию «Select All By Type», Вы можете выделять объекты по их типу - выделить либо все меши, либо все кривые и т. д. Все выделенные до этого объекты станут не выделенными.
  4. Чтобы выделить все объекты, находящиеся на выделенных слоях, нажмите на «Select All By Layer».
  5. Можно также выделить случайные объекты среди всех отображаемых, нажав на «Random».
    BlenderMenu3.jpg
    1. «Percent» - количество в процентах объектов (рассчитывается от количества всех отображаемых объектов), которое будет выделяться или с него будет сниматься выделение.
    2. «Random Seed» - изначальное число, на основе которого будет производится случайный выбор объектов для выделения или снятия выделения.
  6. Для того чтобы инвертировать выделение (все выделенные объекты перестанут быть выделенными, а не выделенные выделяться) выберите пункт «Inverse».
  7. Для снятия выделения или выделения всех отображаемых объектов жмите «De(select) All».
  8. «Circle Select» - выделение кистью.
  9. «Border Select» - выделение прямоугольником.
  10. Выделение связанной геометрии[править]

    Select Linked в Object Mode[править]

    Для выделения связанной некоторыми данными геометрии в «Object Mode» есть пункт меню «Linked».

    1. «Material» - выделить те объекты, у которых такие же материалы, как и у уже выбранных объектов.
        Выделяться только те объекты, у которых есть все материалы уже выбранных тел.
    2. «Texture» - выделить те объекты, у которых такие же изображения у материалов, как и у уже выбранных объектов.
    3. «Particle System» - выделить те объекты, у которых такие же системы частиц (и настройки), как и у уже выбранных объектов.
      Blender Extend.jpg
    4. Если установите галочку у кнопки «Extend» слева, новое выделение будет прибавляться к старому, в противном случае новое выделение заменит старое.

    Select Grouped в Object Mode[править]

    Также для выделения связанной чем-то геометрии есть меню «Select Grouped».

    BlenderBook2.jpg

    1. «Children» - выделит детей последнего выделенного родителя.
    2. «Immidiate Children» - выделит только тех потомком родителя, которые непосредственно привязаны к нему.
      BlenderBook1.jpg
    3. «Parent» - нужен для выделения родителя последнего выделенного объекта.
    4. «Siblings» позволит выделить все объекты с общим родителем.
      1. При том, если выделить сначала объекты одного родителя, потом потомки другого, то будут выделены все потомки-объекты, которые являются потомком последнего родителя.
    5. Для выделения объектов всех одного типа используйте «Type».
    6. «Layer» - выделение всех объектов с того слоя, объекты с которого были выделены последним.
    7. «Group» - даст возможность выделить все тела из одной группы.
    8. «Pass» - выделит все объекты, у которых одно и то же значение параметра «Pass Index» в вкладке «Options».
    9. «Properties» - выделит те объекты у которых есть хотя бы одно свойство как и у последнего выделенного объекта.

    Select Similar в Edit Mode[править]

    В «Edit Mode» добавляется специальный пункт меню «Select Similar» для выделения связанных чем-то полигонов.

    1. «Material» - выделить те полигоны, у которых такие же материалы, как и у уже выбранных полигонов.
    2. «Image» - выделить те полигоны, у которых такие же изображения у материалов, как и у уже выбранных полигонов.
    3. «Perimeter» - выделить те полигоны, у которых такие же периметры, как и у уже выбранных полигонов.
    4. «Flat/Smooth» - выделить те полигоны, у которых такая же сглаженность (Smooth, Flat), как и у уже выбранных полигонов.

    Меню Add[править]

    В меню Add можно выбрать объект, который следует создать.

    Меню Object[править]

    BlenderMenu4.jpg

    1. Convert To - позволяет преобразовать меш в кривую (Mesh from Curve/Meta/Surf/Text) или наоборот (Curve from Mesh/Text).
    2. Show/Hide - дает возможность спрятать или показать объекты в окне 3D вида.
      1. Show Hidden - отобразить все спрятанные объекты.
      2. Hide Selected - скрыть выделенные тела.
      3. Hide Unselected - скрыть не выделенные объекты.
    3. Move To Layer - переместить выделенные объекты на слой.
    4. С помощью команды Join можно объединять объекты.
    5. Чтобы изменить физические свойства, отредактировать свойства в игре можно выбрать один из пунктов из подменю Game:
      1. Copy Logic Bricks - все логические блоки от объекта, которым выделили последним, скопируются и остальным выделенным объектам.
      2. Copy Physics Properties все физические свойства тела, которым выделили последним, скопируются и остальным выделенным объектам.
      3. Replace Properties - все игровые свойства объекта, которым выделили последним, заменят все игровые свойства у остальных выделенных объектов.
      4. Merge Properties - все игровые свойства объекта, которым выделили последним, добавятся к игровым свойствам у остальных выделенных объектов.
      5. Copy Properties - копировать игровое свойство объекта, которым выделили последним, к остальным выделенным объектам.
      6. Clear Game Properties - удалить все игровые свойства у всех выделенных объектов.

    Комбинации клавиш[править]

    Комбинации клавиш Описание
    Shift + H Спрятать все не выделенные объекты
    Shift + L Открыть меню Linked (в Object Mode)
    Shift + G Открыть меню Grouped (в Object Mode)
    Shift + G Открыть меню Select Similar (в Edit Mode)
    B выделение прямоугольником
    Shift+B ограничение области визуализации
    NextChapter.jpg