KiCad/eeschema

Материал из Викиучебника — открытых книг для открытого мира
Перейти к навигации Перейти к поиску
KiCad: руководство пользователя
Программы комплекса
  • kicad: менеджер проектов .
  • eeschema: редактор схем .
  • pcbnew: редактор плат .
  • cvpcb: сопоставление отпечатков компонентам .
  • gerbview: просмотрщик файлов Gerber .
Справка

eeschema – это свободно распространяемая программа с развитыми возможностями для создания принципиальных схем, работающая под операционными системами Linux и Windows Вне зависимости от операционной системы, создаваемые eeschema файлы имеют абсолютно одинаковый формат и полностью совместимы.

Приложение eeschema обладает такими интегрированными возможностями, как изображение схем, контроль электрических цепей, управление библиотеками и связь с программой для работы с печатными платами. Программа позволяет создавать иерархические схемы и управлять связями между ними.

Также eeschema работает в паре с редактором печатных плат pcbnew, которому она передает netlist (список электрических цепей) описывающий связи между элементами на создаваемой печатной плате. eeschema включает в себя возможность создания и редактирования символов (схематических изображений компонентов), их визуализацию, и управление библиотеками компонентов (импорт, экспорт, добавление и удаление их в библиотеках). eeschema имеет все необходимые функции присущие современному программному обеспечению для создания схем:

  • контроль правил дизайна (DRC) для автоматического обнаружения некорректных соединений, болтающихся в воздухе (неподсоединенных) цепей и т.п.
  • Создание выходных файлов схем в формате POSTSCRIPT или HPGL.
  • Создание выходных файлов схем для печати на локальном принтере.
  • Создание bill of materials (список используемых материалов).
  • Создание netlist для передачи его в программу редактирования печатных плат или для симулятора электрических цепей.

Содержание

Основные технические параметры[править]

Функционирование осуществляется в 32-битном режиме, и возможности по обработке электрических цепей ограничены только количеством доступной программе памяти. Таким образом, программа не имеет реальных ограничений на количество выводов компонентов, соединений, листов и т. п. eeschema может работать как с простыми однолистовыми схемами, так и с иерархическими многолистовыми, с немедленным доступом к каждому листу схемы. Размер листа схемы может задаваться и варьируется от формата A4 до A0 или от A до E.

Основные команды[править]

Вызов команд[править]

Есть несколько способов вызова команд:

  • Щёлкнуть мышью по выпадающему меню в верхней части экрана.
  • Щёлкнуть мышью на значке в верхней части экрана (основные команды).
  • Щёлкнуть мышью на значке в правой части экрана (специальные команды или «инструменты»).
  • Щёлкнуть мышью на значке в левой части экрана (опции отображения).
  • Щёлкнуть кнопкой мыши (важные дополнительные команды); Обычно «правый щелчок» открывает контекстное меню, зависящее от того, на каком элементе находится курсор в момент нажатия (команды масштабирования, изменения сетки или редактирования элемента).
  • Фукциональные клавиши на клавиатуре (клавиши F1, F2, F3, F4, Ins и Space).

Как правило: Кнопка Esc позволяет прервать выполнение текущей команды. Кнопка Ins позволяет выполнить дублирование последнего созданного элемента.

Ниже показаны возможные варианты вызова команд редактора схем.

Команды мышью[править]

Основные команды[править]

Левая кнопка: Правая кнопка:
  • Один щелчок: отображение характеристик компонента или текста, находящегося под курсором.
  • Двойной щелчок: редактирование (если элемент допускает редактирование) данного компонента или текста.
  • Открывает контекстное меню.

Операции над блоками[править]

Вы можете перемещать, перетаскивать (электрические связи компонентов при этом становятся как бы «резиновыми», т. е. тянутся вслед за компонентом), копировать и удалять выбранную область схемы при нахождении во всех меню редактора EESchema. Выбор области осуществляется при помощи левой кнопки мыши. Укажите одну из «вершин» области нажатием левой кнопки. Не отпуская кнопки, очертите желаемую область выбора. Отпусканием кнопки зафиксируйте вторую «вершину». Выбранные элементы схемы будут подсвечены. Нажатием клавиш ⇧ Shift, Ctrl, или клавиш ⇧ Shift и Ctrl одновременно, совместно с выполнением операции выбора можно скопировать, перетащить или удалить выделенную область.

Описание команд:

Левая кнопка мыши Переместить выбранные элементы.
⇧ Shift + левая кнопка мыши Скопировать выбранные элементы.
Ctrl + левая кнопка мыши «Перетащить» выбранные элементы.
Ctrl + ⇧ Shift + левая кнопка мыши   Удалить выбранные элементы.

Замечание: комбинация Ctrl + ⇧ Shift + левая кнопка мыши не работает, если в операционной системе комбинация Ctrl + ⇧ Shift используется для переключения раскладки клавиатуры.

Команда выполняется при отпускании кнопки мыши. При перемещении выбранных элементов:

  • Щелчок левой кнопкой – зафиксировать новое положение выбранных элементов.
  • Щелчок правой кнопкой – прервать операцию.

Горячие» клавиши[править]

Замечание: «горячие» клавиши не зависят от регистра. Но зависят от выбранного языка.

  • Del: Удаление (любой элемент).
  • R: Поворот (компонент или метка).
  • X: Зеркальное отображение относительно оси X (компонент).
  • Y: Зеркальное отображение относительно оси Y (компонент).
  • N: Возвращение к «нормальному» положению, заданному в библиотеке (компонент).
  • M: Захват и начало перемещения компонента.

Выбор размера сетки[править]

Курсор перемещается по сетке, отображение которой может быть как включено, так и выключено (при работе с Library Editor и Library Browser сетка всегда включена). Вы можете изменить шаг сетки через выпадающее меню Preferences/Options. По умолчанию, шаг сетки устанавливается равным 50 mil (0.050"), или 1,27 миллиметра (Normal). Доступны ещё два значения шага сетки — 20 mil (Small) и 10 mil (Very Small), но пользоваться ими рекомендуется лишь в особенных случаях, например, для создания или выполнения действий над компонентами, содержащими большое количество выводов (несколько сотен).

Выбор масштаба[править]

Чтобы изменить масштаб изображения (Zoom):

  • Щёлкнуть правой кнопкой мыши, откроется контекстное меню, в котором выберите желаемый масштаб.
  • Или используйте фукциональные клавиши:
    F1: Увеличить масштаб.
    F2: Уменьшить масштаб.
    F3: Обновить изображение.
    F4: Отцентрировать изображение относительно положения курсора.

Отображение координат курсора[править]

Единицы отображения — дюймы (inch или “) или миллиметры. Несмотря на это, внутренняя система единиц Eeschema всегда дюймы, с разрешением 1/1000 дюйма. В правом нижнем углу экрана отображается следующая информация:

  • Значение текущего масштаба.
  • Абсолютные координаты положения курсора.
  • Относительные координаты курсора (можно сбросить показания относительных координат нажатием Space, т. е. установить относительный «ноль»).

Выпадающие меню[править]

С помощью набора команд в выпадающих меню в верхней части экрана можно загрузить в редактор существующую схему, сохранить её (меню «Files»), настроить конфигурацию редактора (меню «Preference»), а также воспользоваться справочной системой KiCad (меню «Help»).

Верхняя панель инструментов[править]

Эта панель инструментов объединяет основные функции редактора EESchema.

 Создать новую схему.
 Открыть существующую схему.
 Сохранить полную схему (вместе с иерархией).
 Выбор размера листа и заполнение основной надписи.
 Вызов редактора компонентов Libedit (просмотр, изменение и редактирование библиотечных компонентов).
 Просмотр библиотек (Viewlib).
 Вызов “Навигатора”, для отображения структуры иерархии текущей схемы (если она содержит вложенные листы схем) и для быстрого переключения между         листами схемы.
 Вырезать выбранные элементы (поместить их в буфер обмена), в процессе выполнения команды Move block.
 Скопировать выбранные элементы в буфер, в процессе выполнения команды Move block.
 Вставить элементы из буфера обмена.
 Отменить команду удаления (до 10 шагов).
 Открыть меню принтера.
 Вызов CVPCB.
 Вызов PCBNEW.
 Изменение масштаба изображения относительно центра экрана.
 Обновить изображение.
 «Показать всё».
 Вызов меню поиска компонента или текста.
 Создание списка соединений - NetList  (в формате Pcbnew или Spice).
 Перенумерация компонентов.
 ERC (Electrical Rules Check) : проверка правильности электрических соединений..
 Генерация файла BOM (Bill of materials) и/или иерархических меток.

Правая панель инструментов[править]

Chap2-commandes html m11a97840.png

Эта панель инструментов дает доступ к командам:

  - размещения компонентов, проводников и шин, соединителей, меток, текста...
  - навигации по иерархии в многолистовом проекте.
  - создания дополнительных листов схемы и межлистовых соединителей.
  - удаления компонентов.

Детальное описание использования этих инструментов приведено в главе «Создание/Редактирование схем».

Их краткое описание приведено ниже.

Chap2-commandes html m6a3ae951.gif Прервать выполнение команды и перейти в режим редактирования.

Chap2-commandes html 56c312a1.gif Перемещение по структуре иерархиского проекта (многолистовая схема): этот инструмент позволяет открыть вложенные листы текущей схемы (щелчок на символе соответствующего листа) или вернуться на предыдущий уровень проекта – в основную схему (щелчок в любом свободном месте открытого вложенного листа проекта). Таким образом, можно быстро переключаться между листами схемы.

Chap2-commandes html 1577da70.gif Вызов меню по размещению компонента.

Chap2-commandes html m253c3ce3.png Вызов меню по размещению портов питания (библиотека "Power").

Chap2-commandes html m3809ab38.gif Рисовать провод.

Chap2-commandes html m3a8b050a.gif Разместить шину.

Chap2-commandes html 3145f3e5.gif Рисовать подключение к шине. Данные элементы служат для наглядности и упрощения чтения схемы и не являются электрическим соединением, поэтому их не следует использовать для соединения между проводами.

Chap2-commandes html 3c9c58ad.gif Соединение между шинами. С их помощью можно соединять шины только между собой.

Chap2-commandes html m45b778c2.gif Символ “Нет соединения”. Его можно размещать на выводах компонентов, которые не должны быть никуда подключены. Удобно применять для корректной работы функции ERC.

Chap2-commandes html m55fad81e.gif Размещение метки локальной цепи. Два проводника на одном листе схемы могут быть логически объединены в одну цепь при помощи подобной метки. Для логического объединения цепей, расположенных на разных листах схемы, необходимо использовать глобальную метку.

Chap2-commandes html m1f34fc07.gif Размещение метки глобальной цепи. С её помощью можно логически объединить цепь расположенную на вложенном листе и цепь на основном (корневом) листе схемы, содержащим символ вложенного листа.

Размещение точки соединения проводников. Служи для соединения двух пересекающихся проводников, или проводника и вывода компонента, если такое соединение выглядит как неявное (т.е. если конец проводника или вывода не соединено, в явном виде, с концом другого проводника).

Размещение символа вложенного листа схемы ( прямоугольник с изменяемыми размерами). Необходимо при этом указать имя файла, в котором будет сохранен этот лист и имя самого листа (как правило они совпадают).

Размещение метки глобальной цепи, импортированной со вложенного листа многолистовой схемы, для логического объединения цепей, находящихся на основном и дополнительном листах. Размещение глобальной метки внутри символа (на основном листе схемы), обозначающего вложенный лист, предполагает, что данная цепь на этом листе уже имеет метку, т.е имеет имя. Метка глобальной цепи эквивалентна обычному выводу компонента и её необходимо подключить к схеме с помощью проводника, по команде «Place Wire».

Размещение метки глобальной цепи, для создания точки соединения символа вложенного листа на основном листе схемы.Global label creation in subsheets to create connection points. Эта команда подобна предыдущей, но при этом не требуется, чтобы на вложенном листе уже была цепь с таким именем.

Создание линий (для рисования контуров объектов).Не является соединительной линией (проводником), а служит лишь для графического оформления схемы.

Размещение текста. Служит для оформления схемы.

Удалить выбранный (выбранные) элементы. Если выбраны несколько наложенных друг на друга элементов, то приоритет отдается нименьшему из них ( в порядке уменьшения приоритета: точка соединения (junction), символ «нет соединения» (no connect), проводник, шина, текст, компонент). Это также применимо и к иерахическим (вложенным) листам схемы. Замечание: команда «Undelete» (отмена удаления), находящаяся в основной панели инструментов, позволяет Вам отменить последнюю операцию удаления.

Левая панель инструментов[править]

Chap2-commandes html m3f7817a7.gif

Эта панель инструментов позволяет управлять режимами отображения:

  Включить/выключить отображение сетки.

  Единицы измерения (дюймы или миллиметры).

  Изменение вида курсора (маленькое или большое перекрестие).

  Скрыть или показать “невидимые” выводы компонентов.

  Переключение между режимами рисования проводников, линий и шин (ортогонально или под под любым углом).

Контекстное меню и быстрое редактирование элементов[править]

Правый щелчок мыши открывает контекстное меню, содержимое которого зависит от объекта на котором находится курсор (если элемент один).

При этом также доступны команды (для мгновенного выполнения):

  • Масштабирования.
  • Настройки сетки.
  • И, в зависимости от ситуации, редактирования параметров элемента схемы.

Chap2-commandes html m364db460.gif

Контекстное меню на свободном поле схемы (не выбран ни один элемент схемы). Chap2-commandes html m68b46157.gif

Редактирование метки. Chap2-commandes html 4c551f43.gif

Редактирование компонента.

Главное меню[править]

Меню Файл (File menu)[править]

Chap3-menu html dce072c.png

Load Project

Загрузить схему вместе с иерархией

Save project

Сохранить схему и все вложенные листы (иерархию)

Save Current sheet

Сохранить текущий лист

Save Current sheet as...

Сохранить текущий лист под новым именем

Print

Вызов меню принтера (см. также раздел «Вывод на печать»)

Plot

Вывод в формате Postscript или HPGL (см. также раздел «Вывод на печать»)

Exit

Выход без сохранения результатов работы

Меню настройки (Preference)[править]

Chap3-menu html m39526f73.png

Libs and Dir

Выбор библиотек и указание пути к ним

Colours

Установка цветовой гаммы

Options

Опции дисплея (единицы измерения, шаг сетки)

Save Config

Сохранить настройки в файле конфигурации

Меню настройки / Библиотеки и Пути (Preferences / Libs and Dir)[править]

Chap3-menu html 2be03acd.png

Конфигурация Eeschema это по существу :

  • Указание путей доступа к библиотекам.
  • Указание списка рабочих (подключенных к проекту) библиотек.
  • Выбор формата для файла списка цепей (Netlist format).


Параметры конфигурации сохраняются в файле kicad.pro (по умолчанию). Однако, можно сохранить несколько различных вариантов настройки рабочей среды ( для разных пользователей или разных проектов) в отдельных файлах с расширением pro.


EESchema будет искать и использовать файл конфигурации в соответствии со следующими правилами:

1. файл конфигурации (<имя проекта>.pro) в рабочей директории.

2. Файл kicad.pro в директории kicad. Этот файл создается при установке программы и используется по умолчанию (default configuration).

3. Значения по умолчанию, если файл конфигурации не найден. При этом, по крайней мере, требуется подключить библиотеки (указать к ним путь) и, после этого, сохранить конфигурацию в файл.

Меню настройки / Цвета (Preferences / Colours)[править]

Chap3-menu html m1427b3d0.gif

Выбор цвета для различных элементов схемы, листа, а также установка цвета фона ( только черный или белый).

Меню настройки / Опции (Preferences / Options)[править]

Chap3-menu html 146a84df.png

Show Grid (Показать сетку):

При установленном флажке: включено отображение сетки.

Grid Size (Шаг сетки):

Для работы применяют сетку normal (0,050 дюйма или 1,27 мм). Меньшие шаги сетки используются при создании компонентов, а также для работы компонентами, содержащими большое число выводов.

Show Pins (Показать выводы):

Включает отображение скрытых выводов (например, выводы питания).

Units (Единицы измерения):

Выбор единиц измерения рабочего поля экрана и координат курсора (дюймы или миллиметры).

Wire / Bus orientation (Ориентация проводников/шин):

Horiz/vertical : допускается рисование проводников и шин только ортогонально (горизонтально-вертикально).

Any :рисование в любом направлении.

Auto Pan (Автопанорамирование):

При установленном флажке, происходит автоматическое панорамирование (сдвиг) окна, если курсор выходит за его границу в процессе рисования или перемещения элемента.

Повторение элемента:

X Step (Шаг по оси X):

изменение координаты по оси Х при дублировании элемента (обычно значение принимается равным 0).

Y Step (Шаг по оси Y):

изменение координаты по оси Y при дублировании элемента (0,100 дюйма or 2,54 мм).

Label Step (Шаг метки):

Шаг инкрементации (декрементации) индекса, стоящего в конце обозначения цепи, при её подключении к шине (например, шина адреса А0-А7 и т.д.). Обычно 1 или -1.

Меню настройки / Язык (Preferences / Language)[править]

Доступны английский или французский язык меню.

После смены языка меню Eeschema необходимо перезапустить.

Справка (Help menu)[править]

Доступ к справке в режиме online (данный документ) , а также, для просмотра текущей версии Eeschema (Eeschema about).

Общая панель инструментов[править]

Настройка листа[править]

Chap4-toolbar html m5ff43702.gif

Кнопка настроек листа:

Chap4-toolbar html m4d05c5e0.png

Редактирование размера листа и титульного блока. Дата обновляется автоматически. Общее количество листов и номер листа обновляются автоматически.

Инструмент поиска[править]

Chap4-toolbar html 32197369.gif

Кнопка поиска.

Chap4-toolbar html 8ac28c53.png

Вы можете искать компонент, значение или текстовую строку в текущем листе или в иерархии схем.

При нахождении элемента курсор установится на найденный элемент в необходимом под-листе.

Инструмент netlist[править]

Chap4-toolbar html 4ff1b2d.gif

Кнопка netlist-а.

Этот netlist-файл может применяться ко всей иерархии (обычное поведение) или только к текущему листу (такой netlist неполный, но может быть полезен для некоторых программ).

В многолистовой иерархии любая локальная метка известна только в пределах своего листа.

Таким образом, метка TOTO из листа 3, отличается от метки TOTO из листа 5 (если они намеренно не соединены связью).

Это связано с тем, что номер листа (определенный командой annotate) ассоциирован с локальной меткой. В предыдущем примере, первая метка TOTO на самом деле имеет имя TOTO_3, а вторая метка – TOTO_5.

Если вам необходимо, то данная ассоциация может быть подавлена, но в таком случае будьте внимательны в связи с возможностью нежелательных соединений.

Примечание 1:

eeschema не имеет ограничений на длину имен меток, но программы использующие сгенерированный netlist, могут иметь это ограничение.

Примечание 2:

Избегайте пробелов в именах меток, так как при этом метка интерпретируется как два отдельных слова. Опять-же это ограничение не eeschema, а различных форматов netlist-ов, которые предполагают отсутствие пробелов.

Chap4-toolbar html 3ac28c53.png

Опция:

Формат по умолчанию:

Установите галочку чтобы выбрать формат Pcbnew по умолчанию.

Так-же могут быть сгенерированы другие форматы:

  • Orcad PCB2.
  • CadStar.
  • Spice, для Spice симулятора.

Инструмент аннотации[править]

Chap4-toolbar html ma678bce.gif

Кнопка аннотации.

Этот инструмент производит автоматическое увеличение номеров designators (обозначений) для компонентов.

Для многоэлементных компонентов (например таких как TTL микросхема 7400, содержащая 4 вентиля), добавляется суффикс (то-есть TTL микросхема 7400, обозначенная как U3, делится на U3A, U3B, U3C, U3D).

Вы можете произвести аннотацию как для всех компонентов, так и только для новых, то-есть которые до этого не были аннотированы.


Chap4-toolbar html m3f37ea6b.gif

annotate (аннотация):

project (проект):

переаннотировать компоненты на всех листах (по умолчанию).

Current sheet (tекущий лист):

переаннотировать текущий лист (эта опция используется только в специальных случаях, например для подсчета количества резисторов в текущем листе).

select items (выбор элементов):

All components (все компоненты):

Безусловная аннотация, все компоненты будут переаннотированы (эта опция используется после копирования блока, например когда получаются дубликаты ссылок)

new components only (только новые компоненты):

Условная аннотация, только новые компоненты будут переаннотированы (по умолчанию).

Кнопки:

Annotate (аннотировать):

Выполнить аннотацию.

Del Annotate (удалить аннотацию):

Удалить аннотацию компонентов.

Инструмент ERC[править]

Chap4-toolbar html m45bd59c1.gif

Кнопка ERC.

Этот инструмент производит проверку электрических правил дизайна (известную как Electrical Rules Check).

Эта функция особенно полезна для обнаружения забытых соединений и противоречий.


eeschema проставляет маркеры на выводах или метках, чтобы показать проблему.

Щелчок на маркере может отобразить диагностику.

Так-же может быть сгенерирован файл ошибок.

Закладка ERC[править]

Chap4-toolbar html 244b1aa9.gif

Ошибки отображаются в диалоге Erc Diags:

  • Errors and warnings count (количество ошибок и предупреждений).
  • Errors count (количество ошибок).
  • Warnings count (количество предупреждений).

Write ERC report: выберите для генерации файла с рапортом о ERC.

Кнопка Test ERC: для выполнения ERC.

Del Markers : для удаления всех маркеров ERC.

Exit : для выхода из этого диалогового окна.

Закладка Options[править]

Chap4-toolbar html m50e84420.gif

Это диалоговое окно позволяет вам установить правила для связей между выводами; вы можете выбрать один из трех вариантов:

  • Нет ошибки.
  • Предупреждение.
  • Ошибка.

Каждый из квадратиков из матрицы может быть изменен щелчком на нем.

Инструмент BOM (билль материалов)[править]

Это меню позволяет генерировать файл листинга компонентов и/или иерархических соединений (глобальных меток).

Компоненты могут быть отсортированы по:

  • Reference (обозначение). Скорее всего необходимо заменить на « designator ».
  • Value (значение).

Можно детализировать составные компоненты. Глобальные метки могут быть отсортированы по:

  • Алфавитной классификации.
  • Под-листам.

Различные типы сортировки могут использоваться одновременно.

Chap4-toolbar html 361b49d8.gif

Возможные опции:

Components by Reference

BOM сортируется по обозначению (Reference)

Component by Value

BOM сортируется по значению (Value)

Sub components

BOM показывает каждый подэлемент из многоэлементных компонентов (таких как U2A, U2B…)

Hierarchy Pins by name

Сортировка иерархических соединений по алфавиту

Hierarchy Pins by Sheet

Сортировка иерархических соединений по номеру листа