Eclipse/Install

Материал из Викиучебника — открытых книг для открытого мира
Перейти к навигации Перейти к поиску

Если при первом запуске Eclipse 3.3 получите сообщение об ошибке, возможно надо обновить JRE (джава-машина в состав Eclipse SDK не входит). Возьмите у Sun или укажите файл виртуальной машины прямо в командной строке: eclipse   -vm   /.../.../bin/java

Убедитесь, что Eclipse SDK использует нужную джава-машину: Window --> Preferences... --> Java --> Installed JREs.

Ubuntu[править]

В Ubuntu может потребоваться отказаться от пред-установленной GNU-версии Джава-машины (GCJ):

  1. Установите java 6: System --> Administration --> Synaptic Package Manager, search, sun-java6-jdk (или sudo aptitude install sun-java6-jdk)
  2. sudo update-java-alternatives -s java-6-sun
  3. sudo gedit /etc/jvm (добавить первой строкой "/usr/lib/jvm/java-6-sun")

На сайте eclipse.org рекомендуют все же использовать «Java 5».

Если окно «Welcome» отображается без графики, добавьте сайнептиком пакет «XULRunner».

[править]

После успешного старта Eclipse SDK скопируйте с Internet и установите патчи: Help --> Software Update --> Find & Install… --> Search for updates of currently installed features (Finish) (пока патчей нет).