Blender 3D: Шаг за шагом (второй вариант перевода)/Моделирование человеческой фигуры

Материал из Викиучебника — открытых книг для открытого мира
Перейти к навигации Перейти к поиску

Создание нового проекта[править]

Ваша фигурка, должна будет выглядеть вот так.

В этом уроке описание того, как создать простую человеческую фигурку.

Если Blender открыт, выберите File>New', или Ctrl-X (удерживая нажатой Ctrl, нажмите X ). Появится строчка с вопросом "Erase All?". Нажмите на этой строчке.

В сцене, по умолчанию, должен находиться куб. Выберите его с помощью правой кнопки мыши (CMD + LMB on Mac). Нажмите клавишу NUM1 ("1" на цифровой клавиатуре),чтобы перейти во фронтальную проекцию. Проверьте, что Вы находитесь в режиме выделения объектов Object Mode. Если куб выделен, Вы можете переключаться между режимом редактирования Edit Mode и режимом выделения Object mode клавишей TAB. Перейдите в режим редактирования.

Напоминание: Кнопка, показанная на этой картинке, показывает, в каком режиме Вы находитесь в текущий момент:

Object Mode Button/Indicator

Соглашения: RMB - правая кнопка мыши, LMB - левая кнопка мыши, MMB - средняя кнопка мыши. (надеюсь, тут перевод не обязателен;))

Методы выделения[править]

Находясь в окне фронтальной проекции, и в режиме Edit Mode, Вам надо выделить четыре верхних вертекса. Возможно,придется несколько повернуть камеру, чтобы выделить именно те вертексы, которые нужны. Попробуйте все методы выделения компонент, их пять:

Файл:Make selection visible.JPG
Кнопка Limit selection to visible (с версии 2.46: Occlude background geometry)

Перед тем, как Вы продолжите, Вам нужно немного повернуть камеру (MMB или для MacintoshALT + LMB) так, чтобы Вы могли видеть все вертексы объекта. Также проверьте, что кнопка "Limit Selection to Visible" включена (в Blender 2.46 эта кнопка называется "Occlude background geometry"). Кнопка - вторая справа в окне трехмерной проекции (она покажет вертексы, которые находятся на заднем плане), она не видна в режиме каркасного отображения (Wireframe Mode), поэтому преключите режим отображения, нажав клавишу Z, если сразу не найдете её на месте.

Примечание: В Blender 2.42 для Mac OS X запущенном на MacBook, существуют аппаратные проблемы с разными режимами выделения: прямоугольное и круговое выделение неправильно отображается на экране (это происходит и на Intel и на PowerPC процессорах).

1. Прямоугольное выделение[править]

Примечание: Этот инструмент рисует прямоугольную рамку выделения, которой Вы сможет выбрать нужные четыре верхних вертекса/точки, у выделенного объекта (бокса).

  1. Снимите выделение со всех объектов (нажав клавишу A)
  2. Нажмите клавишу Tab для редактирования компонент куба
  3. Нажмите клавишу A, чтобы снять выделение со всех компонент редактируемого, подсвеченного объекта.
  4. Нажмите клавишу B, чтобы активировать инструмент Border Select tool - рамка выделения (это будет выглядеть как две линии, которыми надо выбрать начало выделения).

Теперь нажмите LMB и подвигайте курсор - появится прямоугольная рамка выделения. Когда Вы отпустите кнопку мыши, вертексы, оказавшиеся внутри этойрамки, будут выделены.Выделите четыре верхних вертекса. Если Вы сделали ошибку, начните заново, нажав перед этим клавишу A чтобы снять неправильное выделение. Проверьте, что все вертексы не выделены (розового, не желтого цвета), перед тем, как попробовать выделять снова.

Клавиша A - переключает между выделением всех компонент и снятием выделения со всех компонент.

Клавиша B - активизация инструмента прямоугольного выделения.

2. Круговое выделение[править]

Нажатие клавиши С активирует инструмент кругового выделения (Circle Border Select tool).

Вокруг курсора появится контур круга. Вы можете изменить диаметр круга, прокручивая колесо мыши. Подтверждение выделения - кликом LMB. Кроме того, размер выделения можно менять клавишами NUM+/NUM- ("плюс" и "минус" на цифровой клавиатуре) или PgUp/PgDn (для тех,кто не имеет колесика на мыши, или для несчастных пользователей Macintosh). Вы можете выбирать вертексы передвигая круглую рамку выделения над ними, с нажатой LMB (как выделение кистью). Возможно также снять выделение, для этого надо нажать сочетание ALT + LMB, или нажав среднюю кнопку мыши провести над вертексами (при активированном круговом выделении). Кроме того, SHIFT + RMB переключает выделение/снятие выделения на вертексах.

Если комбинация ALT + LMB не действует (вместо этого происходит изменение угла камеры), то для снятия выделения используйте сочетания CTRL + ALT + LMB или MMB.

Попробуйте эти варианты. Инструмент кругового выделения (Circle Border Select tool) будет активным до тех пор, пока Вы не нажмете RMB, ESC или Пробел. Нажмите клавишу A, чтобы снять выделение с вертексов, перед тем, как перейти к следующему методу выделения.

Нажатие С - Инструмент кругового выделения. Используйте клавиши NUM+ или NUM- ("плюс" и "минус" на цифровой клавиатуре), или MW (колесо мыши), чтобы отрегулировать диаметр круга. Деактивация инструмента кругового выделения происходит нажатием RMB или клавиши ESC.

3. Выделение с помощью лассо[править]

Подобно многим графическим редакторам, Blender 3D имеет инструмент лассо (Lasso Select tool). Нажмите сочетание CTRL + LMB, и попробуйте обвести четыре вертекса, это будет похоже на выбор курсором. Отпустите LMB когда закончите выделение. Нажмите клавишу A, чтобы снять выделение с вертексов, перед тем, как попробовать следующий метод выделения. Сочетание CTRL + SHIFT + LMB - метод снятия выделения с помощью лассо.

4. Выделение один за одним[править]

Также Вы можете выбрать четыре вертекса один за одним. Выберите первый вертекс, сверху куба, с помощью правой кнопки мыши (CMD + LMB on Mac). Чтобы выделить следующие вертексы, нажмите и удерживайте клавишу SHIFT и добавляйте вертексы правой кнопкой мыши (CMD + LMB для Macintosh).

5. Выделение полигона[править]

Selection Modes
В добавление к этим методам выделения, вы можете прибегнуть к другому способу: в правой части меню вьюпорта Вы можете видеть маски выделения. Нажмите на кнопке "Выделение полигонов" ("Face select mode", выглядит как треугольник) и выделите верхний полигон куба, с помощью правой кнопки мыши (CMD + LMB для Macintosh). Теперь перелючитесь в "Выделение вертексов" ("Vertex select mode", выглядит как 4 точки, расположенных ромбом), перед тем как продолжить. Как Вы можете видеть, все четыре верхних вертекса стали выделены (это можно назвать "трансформацией выделения").
В качестве альтернативы (курсор должен находиться в окне трехмерной проекции), Вы можете нажать сочетание CTRL + TAB и выбрать строку "Vertices" из выпадающего меню.

Noob Note: If you press NUM1 to get back into the view you need, and then click the face selecting triangle, you can press RMB on each vertex that you need from there. After that if you stay in Face Selecting mode you can press EKey and CTRL and that is the fastest way of expanding.

Экструдирование[править]

Примечание:
Ortographic view
Картинка, которая справа, показывает как включить ортографический вид из камеры. При запуске по умолчанию Blender (2.42), Вы оказываетесь в перспективном трехмерном окне камеры. Чтобы переключиться в ортографическую проекцию, нажмите клавишу NUM5 ("5" на цифровой клавиатуре). В версиях Blender 2.42a и 2.43a, во время экструдирования объектов, как показано ниже, Вы не увидите выпадающее меню Region, поэтому при чтении, игнорируйте эти замечания, все должно работать так же.

Включите фронтальную ортографическую проекцию, нажав NUM1 ("1" на цифровой клавиатуре).

Выделив верхние четыре точки (которые будут выглядеть, как "две" верхние точки в ортографической проекции), нажмите клавишу E. Появится выпадающее меню; выберите строчку Region, затем подвиньте мышь, с нажатой MMB. Вы увидите четыре НОВЫЕ точки, присоединенные к четырем выделенным до этого (Вы можете подвинуть их в любое место, оставить их в нужном положении нажатием LMB, Пробел, или ENTER).

Если Blender, в какой-то момент, предлагает Вам выбрать только ребра, или только вертексы ("Only Edges" и "Only Vertices" в меню перед экструдированием вертексов), значит Вы выбрали не точки, образующие полигон. Это может быть в том случае, если некоторые вертексы продублированы. Выберите все вертексы в режиме редактирования (edit mode) и нажмите клавишу W, чтобы показать особое выпадающее меню, выберите в нам строку "Remove Doubles".

Другой путь удалить дублирующиеся точки: выделите Ваш объект, нажмите клавишу A, чтобы выделить все вертексы этого объекта, и нажмите кнопку "Rem Doubles" в закладке "Mesh Tools" в Окне Кнопок (Buttons Window). Также, Вы можете изменить значение того, как в Blender выделять вершины, которые находятся близко друг к другу.

Если выпадающее меню не появилось (речь идет, видимо, все о меню Region), значит Вы находитесь в режиме выделения полигонов. В этом случае, вернитесь сначала в режим выделения вертексов, кликнув на соответствующую иконку.

Создание ноги фигуры экструдированием[править]

Blender3D Simple Person Step1.png

Клавиша E "экструдирует" вертексы. Если Вы не знали этого слова, возможно, захотите его запомнить. Это обозначение одного из самых широко используемых методов моделирования.

Скорее всего, когда Вы экструдировали вертексы в этом уроке, Вы сделали это в произвольном направлении. Нажмите клавишу U или CTRL+Z (CMD+Z для Macintosh) чтобы отменить эти изменения. Вы снова увидите Ваш оригинальный куб, с четырьмя выделенными вертексами.

С выделенными четырьмя верхними вертексами, нажмите снова клавишу E. Опять выберите Region. В этот раз, во время перемещения вертексов, нажмите и удерживайте нажатой клавишу CTRL. Вы увидите что перемещение будет происходить с определенным шагом (дискретно). Это называется "привязка (snapping)". Вертексы "привязываются" (прилипают) к определенным, предустановленным значениям во время перемещения. Мы поговорим о привязке позже, а сейчас, подвиньте вертексы правильно, так, чтобы результат выглядел, как два куба одинакового размера, стоящих один на другом.

Вертексы, нужные для дальнейшего экструдирования уже выделены. Нажмите клавишу E и выберите Region во второй раз, затем, используя клавишу CTRL, с привязкой, подвиньте вертексы еще раз вверх. Повторяйте этот процесс до тех пор, пока у Вас не получится геометрия из пяти кубов равного размера, "стоящих" друг на друге. Практически, нога фигуры готова!

Подсказка: Не надо делать объект сразу из одного вытянутого (в пять раз) куба, Вам надо создать геометрию из пяти последовательных кубов - иначе у Вас не образуется дополнительных сечений (между кубиками), которые нам потребуются в дальнейшем.
Blender3D Simple Person Step2.png

Нажмите клавишу A чтобы снять выделение с вертексов. Выделите на объекте четыре вертекса в верхнем правом углу фигуры. Вам снова понадобится немного повернуть камеру трехмерной проекции используя MMB (ALT+LMB для Macintosh), чтобы правильно выделить вертексы. Чтобы выбрать два или более вертексов, нажмите RMB и выделите первый вертекс. Затем, нажав и удерживая SHIFT выделите с помощью RMB следующие вертексы. Выделив два верхних вертекса, выделите два вертекса находящихся под ними. У вас должно быть выделено четыре вертекса.

Нажмите клавишу E, выберите Region, и как Вы догадались, нажав и удерживая CTRL переместите вертексы так, чтобы чтобы образовался еще один куб, такого же размера, как и все остальные. Сделайте это еще раз. У Вас получилась левая нога и перемычка между двумя ногами.

Blender3D Simple Person Step3.png

Создание правой ноги фигуры[править]

Если Вы находите, что экструдировать легко и просто - Вы правы. Оставшиеся ступени построения нашей фигурки человека, используют тот же метод экструдирования. Продолжайте экструдирование полигонов, чтобы построить оставшуюся часть фигурки...

Чтобы создать правую ногу, сначала нажмите клавишу A, чтобы снять выделение со всех вертексов. Выделите четыре точки, чтобы вытянуть вниз полигоны, и создать правую ногу. Экструдируйте их так же, как делали до этого. Повторите эту операцию несколько раз, до тех пор, пока правая нога не станет такой же длины, как и левая.

Blender3D Simple Person Step4.png

Торс[править]

Теперь торс! Нажмите клавишу A чтобы снять выделение с вертексов, перейдите во фронтальную проекцию, нажав клавишу NUM1 ("1" на цифровой клавиатуре), выделите четыре верхних вертекса у куба, соединяющего ноги.

Возможно, будет легче выделить точки переключившись в режим выделения полигонов ("Face select mode"), и просто выделить верхний полигон с помощью RMB. Вы обнаружите, что, в этом случае, нажатие клавиши E автоматически переключит в метод экструдирования "Region", так как Вы выбрали непосредственно полигон, а не составляющие его вершины.

Тем же путем, проэкструдируйте полигон "соединительного" куба вверх пять раз, также, как Вы это делали до этого.

Заметки для новичков: Если, в какой-то момент, Ваша модель не помещается в окно трехмерной проекции, Вы можете сместить камеру, нажав и удерживая CTRL, с помощью клавиш NUM4, NUM8, NUM6, NUM2 (соотв. цифры на цифровой клавиатуре), или сначала нажав и удерживая SHIFT, перемещать камеру с помощью MMB.

Blender3D Simple Person Step5.png

Руки[править]

Мы переходим к моделированию рук, которые будут разведены по сторонам, вправо и влево. Переключитесь во фронтальную трехмерную проекцию, снимите выделение, выделите четыре вертекса с левой стороны фигуры, не самые верхние, а находящиеся сразу под верхним рядом точек. Экструдируйте их наружу пять раз, выбрав режим полигонов (Individual Faces).

Проделайте те же операции для правой руки.

Переключитесь в сплошной - solid (не каркасный - wireframe) режим отображения с помощью клавиши Z (см. ниже), и проверьте, что у Вас все получилось правильно. В этом режиме удобнее править модель, если окажется, что некоторые полигоны отсутствуют. Чтобы создать полигон из четырех точек, выделите нужные вертексы и нажмите клавишу F. Или же, Вы можете использовать пункт меню окна трехмерной проекции (вьюпорта) Mesh > Make Edge/Face.

Голова[править]

Теперь добавим нашему нашему персонажу голову. С помощью LMB поместите курсор точки (маркер Блендера) над верхней частью шеи. Убедитесь, что маркер стоит в нужном месте, переключая камеру между фронтальной, боковой и верхней проекциями (используя клавиши NUM7, NUM1 и NUM3 соответственно), и спозиционируйте маркер так, как нужно. Разместив маркер в нужной точке, нажмите клавишу Пробел, чтобы вызвать выпадающее меню. Выберите Add → Icosphere (Добавить → сферу). В некоторых версиях, после выбора команды, появляются под-окна с вопросами - из скольких сегментов должна состоять сфера. Просто нажмите 'ok'. У Вас должна появиться небольшая сфера над фигуркой. Подгоните размер головы так, чтобы она соответствовала пропорциям фигуры, выбрав из меню Mesh → Transform → Scale (Масштабирование ), или просто нажмите клавишу S. Это - все, что надо сделать.


Список горячих клавиш[править]

Описание клавиатурных сокращений, используемых на этой странице:

Клавиша Режим Описание
RMB или CMD+LMB (для пользователей Macintosh) Object Выделение объекта
NUM1 Переключение во фронтальную проекцию
TAB Переключение между режимом выделения объектов, и режимом выделения компонент
B, затем LMB и перемещение Прямоугольное выделение
A Переключение перед выделением/снятием выделения для всех объектов/подобъектов
B B (нажатие два раза), затем LMB и перемещение Круговое выделение
CTRL+LMB и перемещение Выделение лассо
RMB, затем SHIFT+RMB Последовательное выделение (один за другим)
(нажатие на иконке маски выделения вертекс/ребро/полигон) Переключения маски выделения
CMD+TAB (CTRL+TAB для Windows) Выбор режима выделения
Нажатие клавиши E, при выделенных вертексах Экструдирование ("выдавливание")
CTRL в процессе экструдирования Включение привязки
MMB или ALT+LMB Вращение камеры трехмерной проекции
Z Переключение между сплошным/каркасным (wireframe/solid) режимами отображения
F Создание ребра/полигона из выделенных вертексов
NUM3 Переключение в боковой вид (side view) трехмерной проекции
SHIFT+S Привязка курсора или выделения к координатной сетке
G Блокировка текущего выделения и перемещение
Z (или X, или Y) режим перемещения (клавишаG) Фиксация перемещения только по одной оси Z (или по оси X, или по оси Y)
S Изменение масштаба (размеров) выбранного объекта (компонент)
Пробел Вызов меню