Blender 2.49/Beginning Tips

Материал из Викиучебника — открытых книг для открытого мира
Перейти к навигации Перейти к поиску

Буду переводить


Это несколько простых советов, за которыми часто обращаются в той или иной форме. Иногда для того чтобы сделать что-то совсем другое, но в основном всё будет работать также.

Начинаем с куба[править]

Default cube


Главы в этом учебнике часто начинаются с куба, который виден в Blender по умолчанию сразу после запуска. Вот два способа вернуть сцену к начальному состоянию без перезапуска программы:

  • Ctrl-X (удерживая клавишу Ctrl, нажать клавишу X );
  • или выбрать File -> New из меню.

После этого вы увидите диалоговое окно с кнопкой OK? прямо под курсором мыши. Вы можете подтвердить, что хотите удалить текущую сцену щелкнув Erase All (или подвигать мышкой рядом, чтобы убрать окно и отказаться.) Куб выглядит как квадрат в окне 3D viewport. Если повернуть вид с помощью средней кнопки мыши (далее MMB), вы увидите что это на самом деле куб. Он выделен по умолчанию.

Информация

Вы можете изменить сцену по умолчанию (и возвращаться к вашей собственной сцене по нажатию Ctrl-X). Просто измените сцену и расставьте окна как вам нравится, потом выберите пункт в меню File > Save Default Settings. Ваша сцена теперь будет использована по умолчанию когда вы нажмете File > New. Это действительно полезно. Если потом решите сбросить все настройки в то состояние, которое было после установки, вы сможете удалить файл .B.blend, в котором храняться ваши настройки. Этот файл находится в вашем домашнем каталоге. Начиная с версии 2.44 вместо удаления файла можно использовать пункт Load Factory Settings из меню File.

Дробление граней[править]

Дробление граней, или складывание- распространенная техника в 3D моделировании. Она использует математический метод представления кривой поверхности соответствующим расположением контрольных точек или вершин. Это значит, что можно создавать объект с гладкой поверхностью, легко описываемый сравнительно небольшим числом вершин.

Добавление Subsurf-модификатора[править]

Панель "Subsurf modifier" для настройки подграней

Сначала выделите куб. Затем найдите панель кнопок Editing:

  • Щелкните кнопку Blenderediting.png на панели: BlenderEditPanel.png
  • или нажмите F9.

Если вы не видите на панели таких кнопок как Link and Materials, Mesh, Multires, Modifiers, Shapes, то вероятно вы не выделили сам куб. Нажмите A KEY чтобы выделить всё. В окне Modifiers, щелкните на кнопку Add Modifier и выберите Subsurf. Щелкните треугольник справа от надписи Levels:1 Чтобы повысить уровень разбиения на подграни. С каждым увеличением уровня куб становится более гладким с большим числом граней. Если вы нажмете apply (применить) оригинальный куб будет утерян. Если изменения не применять, то они останутся на кубе как своего рода фильтр. В остальных примерах подразумевается что вы не примените изменения (оставите их как фильтр).

Levels (уровень) установлен в 1
Levels установлен в 2



Но я хочу куб![править]

Вам возможно захочется отрендерить модель с использованием подграней. Граните, конечно, но обыкновенно у предметов ребра не слишком остры, если это не лезвие ножа. Это часто упускают из виду новички в 3D. Их графика порой выглядит "слишком совершенной" из-за невозможно острых, ясных, хорошо очерченных ребер. Но Блендеру можно указать, что мы хотим, чтобы наш куб был похож на настоящий. Для этого есть инструмент с названием Edge Creasing (заострение ребра). Всякому краю в Блендере назначается степень остроты, которая говорит модификатору Subsurf, насколько острым мы хотим видеть край. По умолчанию все ребра имеют остроту нулевую, вот почему у куба они исчезают.

Показываем сетку, дробящую поверхность[править]

Subsurfed cube in Edit mode

Вы не забыли что модификатор помнит начальную форму куба? Нажмите TAB чтобы перейти в Edit Mode и увидите оригинальный куб который отображается как сетка вокруг сглаженного куба.

Прежде чем поупражняться со сглаживанием, установите Levels в "4", так чтобы видеть результат более явно.

Выбираем ребра для обострения[править]

Войдите в режим face одним из двух способов:

  • Поставьте курсор на экран 3D View → CTRL+TAB → выберите Faces
  • Перейдите в Edit Mode [1] → кликните Blender Face button (Face Mode Icon).

Выделите одну из сторон у каркаса куба кликом ПКМ у точки в середине грани. Вы узнаете, что она выделена по тому, что прочие грани посереют, а та, что вы выбрали, станет яркой.

Заметим, что хотя мы Face-режиме, обостряться будут именно ребра. Выбор грани - просто быстрый способ выделить ее четырех ребер.

Обостряем выделенные ребра[править]

Editing edge creases

Теперь сделаем острее SubSurf одним из двух способов:

  • Нажмите SHIFT+E
  • Выберите Mesh → Edges → Crease SubSurf.

Курсор мыши свяжет с кубом пунктир. Подвигайте его слегка влево-вправо, чтобы увидеть эффект.

Как принято в Блендере, кликните LMB чтобы принять изменения, или RMB чтобы отбросить.


Наконец строим настоящий куб[править]

All edges creased for a bevelled effect

Или отбросьте ранее сделанное обострение или начните с нуля, чтоб вернуться к сглаженному кубу. Затем нажмите A дважды, чтоб выделить все грани. Обостите их через SHIFT+E как прежде, пока куб не станет как на рисунке справа.

Нажмите TAB чтоб выйти из режима правки. Итого: вы сделали куб.

Сноски[править]

  1. ^  You can change to Edit Mode by selecting it from the drop down list on the 3D Viewport's header. Or, you can toggle between the current mode, and Edit Mode by using TAB.