Mac OS X Tiger/Препарируем Desktop

Материал из Викиучебника — открытых книг для открытого мира
Перейти к навигации Перейти к поиску

</gallery>

Введение[править]

Рис 1. Рабочий стол (Desktop) Tiger.

Когда вы впервые увидите рабочий стол (Desktop) Mac OS X, вы наверняка скажете - "Ух ты! Так бы и съел!". Или "Мамочки, красиво как в музее!". Красивые обои (фотографию или картинку ни о чём) окружают странные загадочные объекты - тонкая, будто из белого пластика, полоска со словами и картинками вверху экрана, а снизу - какая-то ленточка с иконками. Зачем нужны эти штуки и что они могут сделать для вас? Сейчас попробуем разобраться.

Menu Bar - Менюбар[править]

Мой самый любимый бар, Менюбар, всегда находится в самом верху экрана любого Макинтоша. Эта тонкая белая полоса содержит меню приложения, с которым вы прямо сейчас работаете (активного приложения).

Как пользоваться меню[править]

Меню в компьютерах - это списки команд и опций, которыми вы можете воспользоваться. Меню бывают разные и в разных местах, но в этой секции мы будем говорить только о меню в Менюбаре.

Каждое меню в Менюбаре определяется каким-нибудь словом (или символом) - назовем его "заголовком меню". Кликните по заголовку меню и меню появится прямо под ним. Меню будет оставаться открытым, пока вы не выберете в нем какую-нибудь команду или не щелкнете где-нибудь еще. Если меню уже открыто, можно переключиться на соседнее меню, просто передвинув курсор мыши на его заголовок.

Если меню содержит команду, которую можно вызвать клавиатурным сокращением ("горячими клавишами"), это клавиатурное сокращение будет показано прямо в меню справа от команды.

Еще несколько фактов:

  • Пункты меню, которые открывают диалоговые окна, оканчиваются троеточием (...), например - Open..., Save....
  • Некоторые меню - иерархические, то есть меню может быть спрятано "внутри" другого меню. Такие "спрятанные" меню называются "подменю" и найти их можно по маленьким треугольным стрелочкам.
  • Если команду нельзя сейчас использовать, она как бы "потухает" - из черной становится серой. Если все команды в меню потухшие, заголовок меню тоже потухает - но меню все равно можно открыть и посмотреть - какие в нем есть команды.
  • Иногда - очень редко - некоторые команды в меню могут немного меняться, если вы нажмете клавишу-модификатор. Например, команда "Minimize" ("Минимизировать") в меню "Window" ("Окна") большинства приложений превратится в "Minimize All" ("Минимизировать все"), если удерживать клавишу Option.
  • Если меню слишком большое, чтобы уместиться на экране разом, сверху и снизу меню появятся треугольные стрелочки. Подведите к такой стрелке курсор и меню начнет "прокручиваться".

Пройдемся по Менюбару[править]

Хорошо, теперь мы знаем как пользоваться меню. Пройдемся по Менюбару слева направо и посмотрим внимательно на все что встретим.

Меню [править]

Рис 2. Левая часть Менюбара.

С самого левого края Менюбара находится меню , прямо под маленьким синим логотипом Apple. Оно содержит команды, относящиеся ко всему Маку в целом, и всегда на виду. Это следующие команды:

Рис 3. Меню .
  • About This Mac - эта команда открывает маленькое диалоговое окно, в котором рассказывается кое-что о вашем Маке. Также в этом окне есть кнопки, открывающие System Profiler (утилиту, подробно описывающей конфигурацию вашего Мака) и Software Update.
  • Software Update - снова Software Update. Как бы странно это ни звучало, Software Update - это утилита, которая обновляет программное обеспечение.
  • Mac OS X Software - это ссылка на специальную страницу на сайте Apple, на ней можно найти очень много приложений для Mac OS X, многие из этих приложений бесплатные.
  • Dock - Содержит подменю, к которому мы еще вернемся - чуть позже.
  • Location - Этот пункт относится к настройкам сети, если вам нужны подробности - смотите соответствующую секцию этой викикниги.
  • Recent Items - Список файлов и приложений, которые вы недавно открывали или запускали.
  • Force Quit - Если приложение плохо себя ведет и отказывается выгружаться, вы можете применить к нему силу. Щелкните по этой команде - и откроется маленькое диалоговое окошко со списком запущенных приложений. Выберите то, которое вы хотите убить насильственной смертью и нажмите на пульсирующую синюю кнопку "Force Quit". Закончив, закройте окно и просто забудьте о том, что произошло - это безопасная процедура и она не затронет Mac OS X или другие приложения.
  • Sleep, Restart, Shut Down - "Сон", "Перезагрузка", "Выключение". Вроде бы все ясно - эти команды заставят ваш Мак заснуть, перезагрузиться или выключиться.
  • Log Out [Ваше Имя] - Если на вашем Маке несколько учетных записей, вы можете завершать работу под своей учетной записи при помощи этой команды.

Меню Приложения[править]

Рис 3. Меню приложения TextEdit.

Следующее за меню  - прямо справа от него - меню Приложения. Заголовок меню содержит название приложения, которое вы прямо сейчас используете (активного приложения), выделенное полужирным шрифтом. Если вы используете iTunes - заголовок меню соответственно будет "iTunes". Это меню содержит команды, относящиеся ко всему Приложению в целом, включая:

  • About [Название Приложения] - Открывает диалоговое окно, содержащее какую-то информацию о Приложении.
  • Preferences - Настройки большинства приложений меняются в диалоговом окне, которое эта команда и вызывает.
  • Services - Сервисы - отличная штука, это маленькие командочки и действие, которые приложения может позаимствовать у другого приложения. Жалко, правда, что никто в общем особо о сервисах не заботится и толку от Сервисов меньше, чем могло бы быть.
  • Quit [Приложение] - Завершает работу Приложения.
  • Hide [Приложение] - Эта команда делает приложение совершенно невидимым - до тех пор, пока вы не кликнете по его иконке в Доке (Док описывается ниже).
  • Hide Others - Эта команда делает невидимыми все остальные приложения. Их можно "воскрешать" по одному, щелкая по их иконкам в Доке.
  • Show All - Все спрятанные приложения от этой команды снова становятся видимыми.

Интересно какое сокращение можно использовать для show all?

Другие меню[править]

За меню приложения простираются другие меню, содержащие команды приложения, которое вы сейчас используете (активного приложения). Хотя каждое приложение использует собственные меню и команды, некоторые меню (и команды) повторяются довольно часто практически во всех приложениях. Далее мы приведем список из шести самых часто используемых меню (слева направо) и команды, которые вы в них скорее всего найдете - а также стандартные клавиатурые сокращения Apple для каждой из этих команд (если есть).


Меню File[править]

Меню File содержит команды, связанные с тем конкретным файлом, с которым вы сейчас работаете. Обычно в этом меню можно встретить следующие команды:

  • New ⌘ Command+N - Создаёт новый документ.
  • Open ⌘ Command+O - Вызывает диалог "Open" (подробно описывается в следующей главе) и позволяет открыть ранее сохраненный файл.
  • Open Recent - Здесь можно выбрать файл из списка файлов, которые вы уже недавно открывали.
  • Close ⌘ Command+W - Закрывает окно. Заметьте - это не то же самое, что закрыть приложение (в большинстве случаев).
  • Close File ⌘ Command+⇧ Shift+W - Закрывает все окна, связанные с данным файлом.
  • Save ⌘ Command+S - Перезаписывает файл на диске более свежей версией, содержащей только что внесенны вами изменения.
  • Save As ⌘ Command+⇧ Shift+S - Вызывает диалог "Save As". Эта опция позволяет вам сохранит файл, если вы его ещё ни разу не сохраняли - или сохранить отдельную копию файла со всеми вашими изменениями.
  • Save All - Сохраняет на диск все открытые файлы.
  • Revert to Saved - Отменяет все изменения в документе, которые вы сделали с последнего сохранения.
  • Print ⌘ Command+P - Открывает диалог "Print" (подробнее - в следующей главе).
  • Page Setup ⌘ Command+⇧ Shift+P - Позволяет вам выбрать - каким образом печатать документ, ориентацию бумаги, размер листа, размер полей и так далее. Настройки печати тоже сохраняются вместе с файлом.

Меню Edit[править]

Меню Edit содержит команды, связанные с данными, обрабатываемыми приложением и данными, содержащимися в буфере обмена.

Информация

ЗАМЕТКА: Буфер обмена - функция Mac OS X, позволяющая вам хранить кусочки информации прямо под рукой, чтобы переносить и копировать их из одного приложения в другое (или из одного файла в другой, или из одной части файла в другую часть). Его содержимое не изменяется, когда вы переключаетесь из одного приложения в другое, а просмотреть его можно, выбрав команду "Show Clipboard" в меню Edit программы Finder.

Вот самые распространенные команды меню Edit:

  • Undo (⌘-Z) - Отменяет последнее выполненное вами действие.
  • Redo (SHIFT-⌘-Z)- Отменяет эффект команды Undo.
  • Cut (⌘-X) - Удаляет выбранные данные, помещая их при этом в буфер обмена (и перезаписывая то, что было в буфере обмена раньше).
  • Copy (⌘-C) - Копирует выделенные данные в буфер обмена, перезаписывая то, что там было раньше.
  • Paste (⌘-V) - Вставляет содержимое буфера обмена в указанную вами точку. Буфер обмена от этой операции не изменяется, поэтому можно эту операцию выполнить несколько раз.
  • Paste and Match Style - Эта команда появляется в некоторых приложениях, работающих с текстом. Paste and Match style ("Вклеить и Выровнять стиль") вставляет текст у указанную вами точку и подгоняют его стиль к стилю окружающего текста.
  • Delete - Удаляет выделенные данные.
  • Select All (⌘-A) - Выделяет все данные в документе, окне или поле ввода текста.
  • Find (⌘-F) - Открывает окно поиска (текста и не только текста).
  • Find Again (⌘-G) - Повторяет поиск по последнему введенному в окошко "Find" запросу.
  • Special Characters - Открывает Character palette ("Таблицу символов"), в которой можно найти разные спецсимволы или литеры и вставить в файл, с которым вы работаете.

Меню Format[править]

Это меню чаще всего появляется в приложениях для работы с текстом и позволяет изменять форматирование (вид) текста. Зачастую в приложениях, созданных не в Apple, это меню меняется до неузнаваемости. Утвержденный Apple набор команд для этого меню:

  • Show Fonts (⌘T) - Если приложение использует Apple Font Picker - стандартное средство выбора шрифта - эта команда его откроет. Многие приложения - например, Microsoft Office - используют свои собственные средства для этого и этой команды может там не быть.
  • Show Colors (⇧⌘Q) - Помимо Font Picker, Apple предлагает еще и Color Picker - похожее средство для выбора цвета. Если приложение его использует, появится эта команда. Но запутаться всё равно можно: некоторые сторонние приложения (тот же Microsoft Office) используют Color Picker, а вызывать его надо по-другому.
  • Bold (⌘B) - Переключает выделенный текст в полужирное начертание (или выключает полужирное начертание выделенного текста).
  • Italic (⌘I) - Включает или выключает курсивное начертание выделенного текста.
  • Underline (⌘U) - Подчеркивает выделенный текст (или отключает подчеркивание).
  • Bigger (⇧⌘-equal sign) - Увеличивает размер выделенного объекта.
  • Smaller (⌘-hyphen) - Уменьшает размер выделенного объекта.
  • Copy Style (⌥⌘C) - Запоминает как отформатирован выделенный текст и сохраняет это знание на потом.
  • Paste Style (⌥⌘V) - Использует запомненное командой Copy style и форматирует выделенный текст в соответствии с запомненным.
  • Align Left (⌘{) - Выравнивает выделенное по левому краю.
  • Center (⌘|) - Выравнивает выделенное по центру.
  • Justify - Выравнивает выделенное по ширине.
  • Align Right (⌘}) - Выравнивает выделенное по правому краю.
  • Show Ruler - Включает показ линеек.
  • Copy Ruler (^⌘C) - Похоже на команду Copy Style, запоминает выравнивание, табулирование и так далее.
  • Paste Ruler (^⌘V) - Применяет запомненное командой Copy Ruler.

Меню View[править]

Тут находятся разнообразные команды, меняющие то, как показываются данные. Поскольку в разных приложениях отображаются разные типы данных, у каждого приложения свой собственный набор команд в этом меню.

Другие меню[править]

Приложения, которые используют не описанные в этой главе меню, всегда помещают их между меню View и Window (если у приложения вообще есть меню View и Windows, конечно).

Меню Window[править]

Это меню содержит команды, управляюще всеми открытыми приложением окнами (про окна все подробно рассказано в следующей главе).

В каждом меню Windows будут такие команды:

  • Minimize (⌘M) - Свернуть окно - эквивалент нажатия желтой кнопки в текущем окне.
  • Minimize All (⌥⌘M) - Очень удобная опция - сворачивает в док ВСЕ окна текущего приложения.
  • Zoom - Подогнать размер - то же самое, что нажать зеленую кнопку в текущем окне.
  • Bring All to Front - Эта команда берет все окна вашего текущего приложения и помещает их поверх всех других. Размер и положение окон сохраняются.
  • Arrange in Front - Делает то же самое, что Bring All to Front, но размещает при этом окна так, чтобы было видно как можно больше.

Это меню также содержит полный список окон текущего приложения. Если выбрать окно, оно станет самым верхним. Активное окно помечено галочкой, свернутые окна помечены ромбиком, а окна, содержащие несохраненные изменения - точкой.

Меню Help[править]

Меню Help содержит команды, открывающие справочную систему текущего приложения. Хотя в большинстве приложений справка составлена из рук вон плохо, иногда она может быть весьма полезна.

Menu Bar Extras/Менюлетки[править]

Правый край менюбара отличается от левого. Посмотрите туда - если вы человек легко возбудимый, вы можете воскликнуть - "Картинки!!!". Да, этот конец менюбара состоит не только из слов, но и из пиктограмм. Они называются "Menu Bar Extras", (или, если покороче, менюлетки). Менюлетки не меняются, если переключаться между приложениями, они помогают делать всяческие вещи типа изменения громкости звука, показывают заряд батареи и так далее. О разных менюлетках рассказывается в разных частях этой викикниги.

Информация

NOTE: Если места на экране не хватает, чтобы показывать всё содержимое менюбара разом, менюлетки потесняются и освобождают немного места для меню приложения.

Меню Spotlight[править]

Наконец, на самом-самом дальнем правом конце меню находится меню Spotlight, маленькая беленькая лупа в синем кружке. С ее помощью можно получить доступ к поисковику Spotlight, появившемся в Tiger. О нем рассказывается в следующей главе.